Uncategorized

Search Issue “The URL of the item could not be…”

I got the following error when I try to crawl the content using the default zone (in content sources – Local SharePoint Sites)

The URL of the item could not be resolved. The repository might be unavailable, or the crawler proxy settings are not configured. To configure the crawler proxy settings, use Search Administration page

The AAM is configured as below

default zone : http://portal.contoso.local

Intranet zone : http://portal

In the search administration -> content sources “Local SharePoint sites” the start address was configured with url http:portal and  sps3:http://portal…  yuck…

As per the article references below it’s always best practice to crawl the default zone. I noticed the following issues if search content sources is not configured to use default zone.

  1. “Search this site” will return empty results
  2. Document library in-place search (find a file) will return empty results
  3. Usage report (popularity trends) will return zero views

When I changed the content sources to use the default zone I noticed the above mentioned error. The full crawl finished in < 20 seconds. When I referred the crawl log the above error was logged.

To fix this issue add

IP Address of the Web front end in hosts file in (all) application servers.

Useful references

https://wordpress.com/post/16869769/357

http://blogs.msdn.com/b/sharepoint_strategery/archive/2013/02/20/beware-crawling-the-non-default-zone-for-a-sharepoint-2013-web-application.aspx

http://blogs.msdn.com/b/sharepoint_strategery/archive/2014/07/08/problems-when-crawling-the-non-default-zone-explained.aspx

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s